Results 1 to 6 of 6

Thread: Proboat Veles 29 Green blinking/beeping light

  1. #1
    Join Date
    Jun 2020
    Location
    FL
    Posts
    4

    Default Proboat Veles 29 Green blinking/beeping light

    Hello all. I have a new Veles 29 proboat. It ran fine last time I took it out, but after i recharged batteries, when i turn esc on the green light just blinks and beeps every few seconds without any power. Im thinking it could be a battery issue. Any help would be great as i am new to this. Thanks

  2. #2
    Join Date
    Jun 2021
    Location
    MA
    Posts
    148

    Default

    Do you have rudder control? Check esc connection to receiver make sure it's plugged in all the way. May need to recalibrate esc. Turn on transmitter and hold full throttle. Plug in battery and turn on esc. If the esc beeps release throttle. May need to then do full reverse, not sure on esc calibration for that boat. Check the manual.

  3. #3
    Join Date
    Jul 2016
    Location
    IL
    Posts
    3,686

    Default

    I agree with all of eehess81's suggested steps. Also check your throttle trim is still set at zero on the transmitter and that the throttle channel was reversed if the transmitter has a switch for that.
    Vac-U-Tug Jr (13mph)

  4. #4
    Join Date
    Jun 2021
    Location
    MA
    Posts
    148

    Default

    It's usually not a battery issue if there is no damage to battery.

  5. #5
    Join Date
    Jun 2021
    Location
    MA
    Posts
    148

    Default

    I also agree with fweasel on the throttle trim ��

  6. #6
    Join Date
    Jul 2022
    Location
    NJ
    Posts
    1

    Default

    The included transmitter and receiver are bound at the factory. If you need to rebind, follow the instructions below. 1. Ensure the transmitter and vehicle are both powered OFF. 2. Install the bind plug in the BIND/battery port of the receiver. 3. Power ON the vehicle. The receiver LED will blink. 4. Stand approximately 8–12 feet (2.4–3.7m) from the vehicle. With the steering wheel and throttle trigger in the failsafe positions (neutral), press and hold the bind button and power ON the transmitter. The transmitter’s green LED will blink after 3 seconds, indicating it is in bind mode. 5. Release the bind button when the green LED flashes. Continue holding failsafe positions until the binding process is complete. 6. The receiver LED will glow solid when the transmitter and receiver are bound. 7. Power OFF the vehicle, then the transmitter. I had a similar problem when I switched to smart strip lights.
    Last edited by crowwell; 07-18-2022 at 07:31 PM.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •