Results 1 to 20 of 20

Thread: Swordfish X 220A will not connect/program

  1. #1

    Unhappy Swordfish X 220A will not connect/program

    Well I've got to say this has been one of the most frustrating ESCs to deal with ever. Ordered the Swordfish X 220A to go in a P rigger that I'm building for a friend. ESC arrived, I fitted it with connectors and proceeded to try to program it and that's where the fun started. If trying to read the faintly printed microscopic instruction sheet wasn't bad enough neither my laptop or my PC would read the little disc that came with the ESC. So I go to the HiFei web site and attempt to download the instruction sheet and programming software and after a couple of attempts I get them on both the laptop and PC. Go to open programming and it's an unrecognized .rar file so I download the free version of winzip. After screwing with that for a while I finally open and save the file again to both PC and laptop. So I read the hookup instructions for programming and do what it says, open the programming and it just sits there, will not get past the welcome screen (see attached pic). The ESC does emit 3 little beeps when plugging in the USB cable but that's it. So after reading some of the many posts about dealing with these ESCs it seems the standard HiFei reply is relace the programming USB/micro USB cable. While I think it's total BS that they tell to you to go buy a cable to replace the defective one THEY supplied I said screw it and set out to buy one. Well after visits to various places like Best Buy, Batteries Plus etc. this is a cable not to be found locally. I went online and ordered one that will be here Thursday and I'll again attempt programming. So before I attempt again when cable gets here is there anything people who've gotten this version of ESC to work can share with me to get this thing going? This is a crock of you know what but I really feel bad for Steven as I'm sure I'm not the only one to order this thing from OSE and I bet he's getting some grief over it.
    Attached Images Attached Images
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  2. #2
    Join Date
    Jan 2016
    Location
    FL
    Posts
    1,236

    Default

    So it begins. . . AGAIN, just like the older ones where sometimes they work great and sometimes they don't. I think I'm going to definitely hold off getting any of these new SF X escs until all the wrinkles are ironed out. Don, I can honestly say I know exactly how you feel because I've been there. I hope the problem you are experiencing is the extent of if these new SF X escs. I know many of us will be looking forward to this coming Thursday when you try programming it again. . .fingers crossed. . good luck my friend

  3. #3

    Default

    mine only works if I run program as Administrator.

  4. #4

    Default

    Don, you might have better luck using the hand programmer. I tried using the software with no luck, but the hand programmer worked fine.
    Tyler Garrard
    NAMBA 639/IMPBA 20525
    T-Hydro @ 142.94mph former WR

  5. #5

    Default

    Quote Originally Posted by Crash View Post
    mine only works if I run program as Administrator.
    Tried that as well
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  6. #6

    Default

    Quote Originally Posted by RaceMechaniX View Post
    Don, you might have better luck using the hand programmer. I tried using the software with no luck, but the hand programmer worked fine.
    Hand programmer does not work with the X series
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  7. #7

    Default

    I had these issues too, only I managed to luck out and have got to grips with mine 220 and 300's. Initially I had download issues, and found my anti virus was not happy downloading the files and then used win-rar to extract as needed.

    Fixing the cable was not an issue, just a cable not soldered correctly, the cover was loose and thus I found the issue by mistake.

    sf cable.jpg

    As others point out, right click the icon and run the program as "administrator" - I do this after plugging it into the USB port. I've had no issue since.

    Once connected I click the open device button and then edit programming as needed.

    howitlooks.jpg
    Last edited by trigger; 11-06-2018 at 08:30 PM.

  8. #8

    Default

    Quote Originally Posted by trigger View Post
    I had these issues too, only I managed to luck out and have got to grips with mine 220 and 300's. Initially I had download issues, and found my anti virus was not happy downloading the files and then used win-rar to extract as needed.

    Fixing the cable was not an issue, just a cable not soldered correctly, the cover was loose and thus I found the issue by mistake.

    sf cable.jpg

    As others point out, right click the icon and run the program as "administrator" - I do this after plugging it into the USB port. I've had no issue since.

    Once connected I click the open device button and then edit programming as needed.

    howitlooks.jpg
    On your screenshot you show the open device icon in the lower left, I have yet to get that. As I mentioned earlier I did open as admin. Still think that it's BS that HiFei tells you to go buy a new cable at your expense to replace the bad ones that obviously are getting out. I'm hoping I'll have better luck on Thursday when my new cable gets here.
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  9. #9

    Default

    I get that button no matter how I open the software. Maybe try again with the download.

    But I agree it should be easy, you shouldn’t need a PhD in computer science to figure this out.

    Stick with it. You’ll crack it.

  10. #10

    Default

    I had no problem programming the Pro-200 amp with data logging but then I used the following -

    Hifei V4.11 software
    XP Pro operating system (32 bit from memory)
    Hobbyking USB programmer (linker) and programming cable supplied with the linker

    Make sure you check which Com port you are using for the Hifei software. I tried Hifei V5.02 but could not get to work. From memory many had programming issues using Microsoft 10.

  11. #11
    Join Date
    May 2007
    Location
    NY
    Posts
    1,551

    Default

    Quote Originally Posted by don ferrette View Post
    On your screenshot you show the open device icon in the lower left, I have yet to get that. As I mentioned earlier I did open as admin. Still think that it's BS that HiFei tells you to go buy a new cable at your expense to replace the bad ones that obviously are getting out. I'm hoping I'll have better luck on Thursday when my new cable gets here.
    That is exactly why I dumped them and went back to Castle. They sell you a faulty cable and then tell you to buy a new one. BTW mine worked again when I got the new cable but I didn't keep mine long enough to see for how long it worked.
    Team Liquid Dash

  12. #12

    Default

    Quote Originally Posted by Old School View Post
    I had no problem programming the Pro-200 amp with data logging but then I used the following -

    Hifei V4.11 software
    XP Pro operating system (32 bit from memory)
    Hobbyking USB programmer (linker) and programming cable supplied with the linker

    Make sure you check which Com port you are using for the Hifei software. I tried Hifei V5.02 but could not get to work. From memory many had programming issues using Microsoft 10.
    Completely different unit from the new X series and not programmable with program boxes as previously posted.
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  13. #13

    Default

    I have the 200X and had to download the V6.0 from Hifie website. (actually Jay figured it out for me) The ESC works after programing it but the data logger does not register. Shame on me for trying another Swordfish product. I wish there were more options under $250 for 200 amp esc's.
    Mic

    Mic Halbrehder
    IMPBA 8656
    NAMBA 1414

  14. #14

    Default

    Quote Originally Posted by HTVboats View Post
    I have the 200X and had to download the V6.0 from Hifie website. (actually Jay figured it out for me) The ESC works after programing it but the data logger does not register. Shame on me for trying another Swordfish product. I wish there were more options under $250 for 200 amp esc's.
    Mic
    Yeah Mic right there with you on that one. I downloaded the 6.01 software, hope when cable gets here tomorrow I can get this thing working.
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  15. #15

    Default

    Wouldn't it be great if someone would make the T-180 V2 again? I have had two SF220 esc's and both were rubbish, lasted only a few runs and died. T-180 no problems in the same boats!
    Trying to get my Q hydro working with a YEP 180 HV esc but the start up is a bit slow being a watercooled plane/heli esc. The T-180 that I have had in it has developed issues after about 6 years of use.
    NZMPBA 2013, 2016 Open Electric Champion. NZMPBA 2016 P Offshore Champion.
    2016 SUHA Q Sport Hydro Hi Points Champion.
    BOPMPBC Open Mono, Open Electric Champion.

  16. #16

    Default

    Quote Originally Posted by trigger View Post
    I get that button no matter how I open the software. Maybe try again with the download.

    But I agree it should be easy, you shouldn’t need a PhD in computer science to figure this out.

    Stick with it. You’ll crack it.
    Do you get the open device button with ESC connected, not connected or both? New cable arrived today (not from HiFei) and it still isn't doing squat. I even deleted and downloaded/reinstalled software. Getting seriously pissed off..........
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  17. #17

    Default

    I get the button no matter how I open the software.

    I’m running windows 10 if that helps. If you get desperate you can send it me and I can program how you want it......

  18. #18

    Default

    Here is a screen grab once I went to the HiFei web site and clicked the file, I double clicked it as an icon at the bottom of the screen once it was downloaded. This dialogue box opens, I then hit the extract file button. Its a cinch from there.

    Extract the file to the desk top or place of your liking, then install as you would from the CD. (from memory I think there was a .exe file to run)

    screen.jpg

  19. #19

    Default

    Quote Originally Posted by trigger View Post
    I get the button no matter how I open the software.

    I’m running windows 10 if that helps. If you get desperate you can send it me and I can program how you want it......
    Tried both W7 on laptop and W10 on PC, all with the same results. Deleted and reloaded multiple times, seems like I'm just wasting time now. So totally regret buying this ESC, I may take you up on the offer to send it over to you as I've ttried everything here. I pm you later today.
    Giant Power Team Driver
    - IMPBA Hydro Technical Director - IMPBA District 12 Scale Director -

  20. #20

    Default

    Don last resort try loading it onto a USB stick and run it from there, that was the only way I could get the older version to work for me. It wouldn’t work on the same drive as the OS.


    Sent from my iPad using Tapatalk
    Namba District 16
    1/8 Squire Shop nitro,1/8 59 Maverick nitro, 1/8 Executone FE (UC)1/8 Smokin Joe FE,MLGSX380,AC Pro40II Q Sport,AC Pro40II nitro,Twincraft mono 10s,Vision AOPC,VS1 FE,Insane 30.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •