Results 1 to 8 of 8

Thread: How do you handle this?

  1. #1

    Default How do you handle this?

    So I had my proboat mystic setup to run on 5s with a leopard 4074 1800kv turning an m545. I took the as far forward as I could where my battery was up against the ESC.

    I drop the strut to the lowest point and put a little negative in it hoping to lift the back of the boat and get it running level.

    When I lightly pull the trigger like 10 to 15% throttle the boat almost completely lift out of the water on the prop alone. Then the bow drop and it was sailing decent. Then I squeeze to 100% throttle and the boat pitch out of the water into the air and fly like 15 or 20 feet forward.

    See attach link.

    https://youtu.be/yk-H0q3OHWk

  2. #2

    Default

    Looks like the hull is getting to much air under the nose, you need to get the c.o.g. more up front.

  3. #3

    Default

    Let’s see some pictures of the setup. Start from zero. Make the strut flat to the bottom and put your COG at about ⅓ from the back. Then start moving things one at a time.


    Sent from my iPhone using Tapatalk

  4. #4

    Default

    Try a different prop also...

  5. #5

    Default

    Thanks guys, I don't know how to upload photos to this site.

    I used to run with the strut higher, but as speed increased I dropped it lower to keep it on the water.

    At present I have strut set to the lowest point. And I filed off some of the brass tubing to get some negative in the strut angle.

    The cg was at 35.5%.

    I did those things to keep it from standing up on the prop from hard acceleration.

    I did some prop work and the boat is a lot more responsive to throttle input. That video that I post it was not windy at that time.

    I think a combination of my prop work and other measures to maximize power going to the motor. Has the boat behaving so.

    I will try carrying the cg as far forward as I can.
    https://youtu.be/_Y6mW7Klh_0

    Here is a video running in another location.

  6. #6

    Default

    Well I give you credit, that thing is singing along over that rough water. That is really something to see. Hard to keep a 30” boat on that water at that speed.

    But in the first vid I’d say your prop is too deep in the water. The prop is literally pushing the boat out of the water. Keep track of your settings for that rough water but for the smooth water get the strut up some. Let the hull ride.

  7. #7

    Default

    yes that hull is getting too much air under causing the excessive lift . back up nose down maybe add a wind dam to the tunnel area.

  8. #8

    Default

    Thanks for the replies. I try some of the suggested things.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •