Results 1 to 4 of 4

Thread: Spectrum DX5R

  1. #1
    Join Date
    Jul 2017
    Location
    VI
    Posts
    80

    Question Spectrum DX5R

    Hi guys i just bought a brand new dx5r from spectrum to replace my old futaba t3pk magnum and i am having a issue with it. I use a seaking 180 amp esc which the light canges from red to green when hull throttle is applied. My issue is that when I use the spectrum the colour does not change which means that it isnt going full speed even when the trigger is pulled all the way back. I have tried rebinding it but that has not solved the problem. Could you help me please.

  2. #2
    Join Date
    Jul 2016
    Location
    IL
    Posts
    3,044

    Default

    Turn off esc, turn on transmitter, hold throttle at 100%, turn on esc whith throttle still at 100%, wait for two beeps, let go of throttle, wait for a few more beeps, power esc off, then back on again. Should be good to go assuming the problem isn't a trim or reverse setting issue.

  3. #3
    Join Date
    Jul 2017
    Location
    VI
    Posts
    80

    Default

    Quote Originally Posted by fweasel View Post
    Turn off esc, turn on transmitter, hold throttle at 100%, turn on esc whith throttle still at 100%, wait for two beeps, let go of throttle, wait for a few more beeps, power esc off, then back on again. Should be good to go assuming the problem isn't a trim or reverse setting issue.
    Thanks man I just did what you said and it worked perfrctly.

  4. #4
    Join Date
    Jul 2016
    Location
    IL
    Posts
    3,044

    Default

    Nice, glad to hear that. Whenever you change an ESC or receiver, you need to redo the throttle calibration procedure. It's not always the same method, but many ESC's do use the steps listed in my post.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •