Results 1 to 23 of 23

Thread: ZTW Seal boat esc's

  1. #1
    Join Date
    May 2007
    Location
    NY
    Posts
    1,556

    Default ZTW Seal boat esc's

    Just curious if anybody is using the ZTW seal esc's yet? Can't seem to find much info on them.
    Team Liquid Dash

  2. #2
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    A friend of mine knows two guys who had bad luck with them. One lasted two passes, the other lasted about 18 seconds. Until I started looking around, I was going to get two 300A units, but I'll just go with the Swordfish X now.

  3. #3
    Join Date
    Oct 2013
    Location
    la
    Posts
    8,722

    Default

    I really like the new swordfish x.
    32" carbon rivercat single 4s 102mph, 27” mini Rivercat 92mph, kbb34 91mph, jessej micro cat(too fast) was

  4. #4
    Join Date
    Oct 2013
    Location
    la
    Posts
    8,722

    Default

    Wow. I didn’t even know Ose carried these. They look pretty cool. I like the design. Any experienced boaters tried these yet?
    32" carbon rivercat single 4s 102mph, 27” mini Rivercat 92mph, kbb34 91mph, jessej micro cat(too fast) was

  5. #5
    Join Date
    May 2007
    Location
    NY
    Posts
    1,556

    Default

    Quote Originally Posted by kfxguy View Post
    I really like the new swordfish x.
    No problems at all? Just picked up a boat with one installed and I am hoping it will be good to go.
    Team Liquid Dash

  6. #6
    Join Date
    Sep 2011
    Location
    Tx
    Posts
    159

    Default

    I bought a 200a ztw I will be running in my 8th scale hydro. Maiden voyage is next Saturday. I will post back afterwards.

  7. #7
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Quote Originally Posted by eric113 View Post
    I bought a 200a ztw I will be running in my 8th scale hydro. Maiden voyage is next Saturday. I will post back afterwards.
    Please do!! I don't care to burn up $500 if they're crap.

  8. #8
    Join Date
    May 2018
    Location
    TX
    Posts
    196

    Default

    My 200A is working great.

  9. #9
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Quote Originally Posted by Mike W View Post
    My 200A is working great.
    What are you running with it?

  10. #10
    Join Date
    Jul 2016
    Location
    IL
    Posts
    2,841

    Default

    Steven V has been testing them for a little while now and has positive things to say about them. I don't recall exactly which models he's been running. Some of the early failures I've read about were very early on in production, not the models I see available now. I agree, those 300A units look beefy and have a lot of caps on them.
    Vac-U-Tug Jr (13mph)

  11. #11
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Ok cool.

  12. #12
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Unfortunately, no data logging.

  13. #13
    Join Date
    Jun 2018
    Location
    WI
    Posts
    19

    Default

    I am thinking of using them in my twin 53'' cat but won't buy till they are out for a bit... I just have a Swordfish die with only two runs on it. Worked just fine whet to run it a 3rd time and it won't start back up.... Seems to be like most things today made in China you mite get a good one or you mite not........

  14. #14
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Was it the Swordfish X ? I just bought the 220 for my Geico boat. However, I'm still waiting for the Radtek to show up and in need of two 300A controllers for it. Two MGM's would cost about $150 more that the SF X 300's. May buy them, but that's a lot of $$$.

  15. #15
    Join Date
    May 2018
    Location
    TX
    Posts
    196

    Default

    Quote Originally Posted by Prodrvr View Post
    What are you running with it?
    Running it pretty hard with a TP4050 1950KV 6S5000 4x1000uF 1716 in a Genesis for a full 5 minutes at 77mph in the straights.

  16. #16
    Join Date
    Jun 2018
    Location
    WI
    Posts
    19

    Default

    It was a 300 Plus with 1k motor running on 6s with 9 63v 1000uf caps only got two runs out of it before it stop working....

  17. #17
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Quote Originally Posted by Mike W View Post
    Running it pretty hard with a TP4050 1950KV 6S5000 4x1000uF 1716 in a Genesis for a full 5 minutes at 77mph in the straights.
    Nice!

  18. #18
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Quote Originally Posted by Gofast12s View Post
    It was a 300 Plus with 1k motor running on 6s with 9 63v 1000uf caps only got two runs out of it before it stop working....
    That's it???

  19. #19
    Join Date
    Jun 2018
    Location
    WI
    Posts
    19

    Default

    Two runs from one of the two Swordfish 300+ The other one still works fine.... Problem being the 300+ is no longer made and Swordfish has a very bad return record. Logger showed it working just fine no high heat no high voltage no high amps rpms high point of 2130 so WTH ????? I'm going to get inside of it and see why it won't work even if I have to cut the outer case in half to do it. What do I have to lose $300 LOL I'm out $600 because one ESC is no good with a twin cat is it. The good ESC is going in the hydro that was gas now I get need a motor.... Mad that I need to get a new set of high dollar ESCs to run my newer cat because one ESC takes a crap...... I won't buy a swordfish ever again waiting to see how the ZTWs are!

  20. #20
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    The more I read, the more I want to just bite the bullet and get a pair of MGM's.

  21. #21
    Join Date
    Sep 2012
    Location
    Tg
    Posts
    1,036

    Default

    Quote Originally Posted by Gofast12s View Post
    Two runs from one of the two Swordfish 300+ The other one still works fine.... Problem being the 300+ is no longer made and Swordfish has a very bad return record. Logger showed it working just fine no high heat no high voltage no high amps rpms high point of 2130 so WTH ????? I'm going to get inside of it and see why it won't work even if I have to cut the outer case in half to do it. What do I have to lose $300 LOL I'm out $600 because one ESC is no good with a twin cat is it. The good ESC is going in the hydro that was gas now I get need a motor.... Mad that I need to get a new set of high dollar ESCs to run my newer cat because one ESC takes a crap...... I won't buy a swordfish ever again waiting to see how the ZTWs are!
    Agree with you the Sf esc's, have only had two 220A and both lasted less than 10 runs. The V2 T 180 was awesomw, why did they ever stop making it and not make a bigger version, IDK!
    NZMPBA 2013, 2016 Open Electric Champion. NZMPBA 2016 P Offshore Champion.
    2016 SUHA Q Sport Hydro Hi Points Champion.
    BOPMPBC Open Mono, Open Electric Champion.

  22. #22
    Join Date
    Sep 2011
    Location
    Tx
    Posts
    159

    Default

    Quote Originally Posted by Prodrvr View Post
    Please do!! I don't care to burn up $500 if they're crap.
    I been running mine in 8th scale hydro on 8s and been fine. Other guys in club run 200a in P mono and P sport hydros with no problems. I live in Texas where been upper 90’s-100’s during the summers.

  23. #23
    Join Date
    Jul 2015
    Location
    FL
    Posts
    701

    Default

    Quote Originally Posted by eric113 View Post
    I been running mine in 8th scale hydro on 8s and been fine. Other guys in club run 200a in P mono and P sport hydros with no problems. I live in Texas where been upper 90’s-100’s during the summers.
    Sounds good. I also got another recommendation for these from a high end boat builder.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •