Results 1 to 5 of 5

Thread: ProBoat Jet Jam Random Cavitation

  1. #1

    Default ProBoat Jet Jam Random Cavitation

    Hello all. This is my first post. I noticed that our Jet Jam boats randomly cavitate (or ventilate) when the water becomes slightly choppy. It seams as if the jet drive system gets too much air inside the chamber which causes the boat to stop temporarily until I let off the throttle and let the chamber fill back up with water again. When it first happened, it sounded like the impeller shaft came loose because I could hear the motor revving but the boat sat motionless. There's no way to move components around to balance the weight inside the hull so I'm not sure what to do. Any ideas?

  2. #2

    Default

    Mine does the same thing. My bigger issue is that it fills with water and turns into a submersible before the battery is dead. Thought it was the hatch, but used tape on the 2nd outing and it quickly took on water again. Must be coming through the screw holes in the bottom of the hull.
    HPR C5009 Mystic twin, Genesis 37, Zelos 36 twin, Voracity 36, Miss Geico 29 V3, King of Shaves P1, Mini Zonda 27, Miss Budweiser 1/12, Delta Force 26, Offshore Infinity, Stealthwake, Vac-U-Tug Jr

  3. #3

    Default

    Thanks for the reply. At least I know I'm not alone. I installed a brushless motor and a 3S Li-Po in one of the boats. it's much faster but amplifies the problem even more. Going to do research on different impellers. Oh, and yes, my jet jam takes on water too. I cut up a dish sponge and applied the pieces of sponge inside the hull toward the stern. The sponge effectively collects the water, but it sucks that I have to do that.

  4. #4

    Default

    Unfortunately it is the nature of the beast that jet drives aren't as good as props in the rough, that is what you get for having no drive parts below the planing surfaces, but on the plus side the draft of water needed to run is much reduced and it is much harder to break an impeller than a prop.

    Jet drives are high volume low pressure pumps, and are nor self priming, when the intake comes out of the water it can't pull enough vacuum to pull water up the intake, you have to wait for the boat to come off the plane and settle down in the water enough that the boat's displacement fills the intake with water and the impeller now in water can pull more water up the tube.

    There are a few things you can easily do to improve things. Firstly you can round over the front edge of the inlet lip so that at speed the boundry layer of water that sticks to the bottom of the hull can smoothly run up into the tube. Conversely sharpening the rear edge of the inlet lip will make more of the water that hits the lip go up the tube instead of back along the bottom of the hull. The biggest improvement would com if you built a scoop at the back of the lip to force water up the tube as soon as it touches back down on the water, but it is something sticking down to get broken if you run white water with it, and it will add some drag at high speed. Finally you could also remove the grill which would ease the flow of water up the tube, but obviously at the cost of an increased chance of sacking foreign objects up the tube and breaking the impeller.
    Paul "tug Killer" Upton-Taylor, Cat lover.
    FastElectricBoats.co.uk

  5. #5

    Default

    Thanks for the advice NativePaul. I may try modifying the intake gate as you mentioned. I saw a video of a brushless powered Jet jam right here on this forum that looked like it was not suffering from any cavitation issues at all. It was flying across the pond like nobody's business. That boat was equipped with an Octura X427 prop in place of the tiny impeller. I've ordered a X427 from Offshore Electrics and plan on swapping out the impeller to see if that helps. I'll keep you all posted, but thanks again for the quick reply.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •