Results 1 to 10 of 10

Thread: ETTI 125 or ETTI 100 amp ESC?

  1. #1
    Join Date
    Feb 2008
    Posts
    413

    Default ETTI 125 or ETTI 100 amp ESC?

    Anyone using ETTI esc? Some infos please. Thanks

  2. #2
    Join Date
    Jul 2008
    Location
    zw
    Posts
    237

    Default

    I would say it depends on the motor .

  3. #3
    Join Date
    Jun 2007
    Location
    FL
    Posts
    1,494

    Default

    At the moment the ETTI 150 Race controller is the best bang for the buck.

    All the best,

    Ray

  4. #4
    Join Date
    May 2008
    Posts
    200

    Default

    YEP IAM IN NEED OF HELP TO I HAVE AN ETTI 150AMP

  5. #5
    Join Date
    Jul 2008
    Location
    zw
    Posts
    237

    Default

    Quote Originally Posted by MAXAMUS View Post
    YEP IAM IN NEED OF HELP TO I HAVE AN ETTI 150AMP
    You need help with buying a ETTi 150 or you have a ETTI 150 and need our help with programming ?
    The best thing you can do if you want to buy a ETTI just send a email to the ebay shop owner , ETTI Marine RC Shop and just tell him what you need . Pay him with Pay-Pall and it will be send to you .

    At least this is how i order from him .

  6. #6
    Join Date
    May 2008
    Posts
    200

    Default

    i have an Etti 150 amp already just cant get the darn thing to set up properly

    i have a red light on but no noises beeps etc and the prop spins at mega low rpm and judders think its spinning anti clockwise have tried swapping over two of the wires from the esc but still no joy think iam in need of some big time help

  7. #7
    Join Date
    Nov 2008
    Location
    SA
    Posts
    708

    Default

    I also ordered a Etti 150 for use with my Feigao 10XL and 2x 11,1V lipos in a 31" cat. Any tips on programming and seting it up?

  8. #8
    Join Date
    Mar 2007
    Location
    VA
    Posts
    7,146

    Default

    Quote Originally Posted by MAXAMUS View Post
    i have an Etti 150 amp already just cant get the darn thing to set up properly

    i have a red light on but no noises beeps etc and the prop spins at mega low rpm and judders think its spinning anti clockwise have tried swapping over two of the wires from the esc but still no joy think iam in need of some big time help
    It sounds like the "motor poles" or "timing" setting. Find out how many poles your motor is and set the ESC accordingly.
    Last edited by Diegoboy; 11-18-2008 at 08:50 AM.
    "A quick temper will make a fool of you soon enough."
    . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .Bruce Lee. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

  9. #9
    Join Date
    Nov 2008
    Location
    SA
    Posts
    708

    Default

    Quote Originally Posted by lomdel View Post
    I also ordered a Etti 150 for use with my Feigao 10XL and 2x 11,1V lipos in a 31" cat. Any tips on programming and seting it up?
    I got a pdf set-up manual for the 150 from Etti themselves. PM me and I'll e-mail it.

  10. #10
    Join Date
    May 2008
    Posts
    200

    Default

    Quote Originally Posted by lomdel View Post
    I also ordered a Etti 150 for use with my Feigao 10XL and 2x 11,1V lipos in a 31" cat. Any tips on programming and seting it up?
    if you have any problem programming the Etti 150amp pm me

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •