Page 1 of 2 12 LastLast
Results 1 to 30 of 39

Thread: Dear Castle Creations.....

  1. #1
    Join Date
    Jul 2007
    Location
    mn
    Posts
    658

    Default Dear Castle Creations.....

    I might be a bit off here ... But I am thinking castle needs to step up and make a statement about the sitution. They need to offer a set of instruction on how to deal with the update version. It seems that ervery few days there is a new post stateing the same problem with different words....


    Castle Its time to step up...... Heck and I dont even own one.
    And the way things are going I may not.... Maybe Steven can get some pull on this topic...

  2. #2
    Join Date
    Jan 2008
    Location
    AU
    Posts
    541

    Thumbs up

    well said lonewolf.

  3. #3
    Join Date
    May 2007
    Location
    NY
    Posts
    1,556

    Default

    I started a thread over on RC Groups in the Castle Creations section hoping to get Castle's attention. I will say that Joe Ford has been in contact with me about the firmware so hopefully once they get back to work after the long weekend I will have a reply.
    Team Liquid Dash

  4. #4
    Join Date
    Jul 2007
    Location
    mn
    Posts
    658

    Default

    My point is that Castle should make the statement... We as the consumer should be offered a solution to a problem that was not of our doing. It is appreciated that you do this for us But it should come from them, they could post threads at the few major forums.....And get the word out verses a customer haveing to email them and forward the info here.
    They are the primary esc supplier to this hobby They need to back up their end of the support that they charge you guys for...

  5. #5
    Join Date
    Apr 2007
    Location
    wa
    Posts
    1,384

    Default

    I agree but so far there are many out there that have had no issues with either and all their esc's. Even the HV models. I would just hate to see them back out now and go back to their non cooled lower amperage line for just planes and auto's. They are expensive and with any electronics your taking a chance. However they do seem like they have good customer service on that end. Which is the Main reason I have stopped using the overseas products. I had a Hex outta the package give out and tried to just contact the seller to see how to return using my 1 year warranty and I was on my wild goose chase from there on. I knew I would get nothing but thats why they are cheaper in price than hydra's in my opinion. sell 4 and one is bad you have made your money and dont have to back it up is their opinion.

  6. #6
    Join Date
    Jun 2007
    Location
    BC
    Posts
    5,190

    Default

    An interesting thread, I own a Barracuda 80 and a Hydra 120, as long as I have stayed with updates that seem to have no issues...no problems. Apart from that, Castle stand behind thier product but seem to be guilty of overstating their perfomance with lipo.
    The only ESC that I know of with no problems within their stated guidelines are Schulze, but they are beyond my budget. Their in lies the dilemma, manufacturers who MAY not understand the dynamics that FE boating demands and if they do not state their ESC has been tested for boat useage, be very cautious. As most FE boaters push the envelope on their equipment and then get upset when the equipment ends up in flames. I suggest that as has been previously proposed by many seasoned boaters you use a 70% rule on specs. But as Raydee has mentioned, Castle needs to address their update issues.
    My no cents.

    Douggie
    Last edited by Flying Scotsman; 09-02-2008 at 02:04 PM.

  7. #7
    Join Date
    Apr 2007
    Location
    ma
    Posts
    8,636

    Default

    What major problems are you seeing?
    Steven Vaccaro

    Where Racing on a Budget is a Reality!

  8. #8
    Join Date
    Jan 2008
    Location
    Mo
    Posts
    2,716

    Default

    With all the posts about issues I am not sure I can still justify owning one either and they are just a couple hours away from me.

    Joe and the whole gang seem to but top notch in PR and warranty. Obviously some of the issues are shear idots using them but then there are just as many with bad software and issues like plugging them in and poof.

    I would like to own a couple but seems there is new software every darn week or two and I, for one, can't deal with that. Build the first time and know what it will do.

    Updates mean 1 thing to me...not enough testing.

    I hope to purchase a few when it all settles down....until then I will keep beating the crap out of the $60-100 units and be happy.

  9. #9
    Join Date
    Apr 2007
    Location
    WA
    Posts
    8,310

    Default

    I've been using Castle ESCs exclusively for over 4-seasons now for my brushless motor needs... I've run them with and without BEC... for 2S, 3S, and 6S applications... with Nemesis, SV, Ammo, Hacker, HiMax, and Neu Motors of all different sizes and amp draws... I've run B125 ESCs in applications that people SWEAR are drawing over 150amps... I've run them for extended periods at part throttle (rough race water)... And I've raced with a whole group of guys that have done the same...

    To date, I've had ONE ESC fail, and all it did was blow a cap and melt the solder on one of the power leads... Castle replaced this promptly, even though it was about 4-months out of warrantee...

    These controllers are SOLID. They work well, are race proven, and hold MANY records, NAMBA and IMPBA, both oval and SAW.

    I'm not sure what problems people are having, but I think it's a little unfair to immediately blame the hardware or software, when there is such a proven track record of success with these things. A thorough analysis of the surrounding hardware and setup needs to be done to really figure out what's going on. I suspect that many of these failures could have or can be prevented with some simple initial prep steps, such as filling the controller plug with dialectric grease and applying some corrossion-X before the initial use. These controllers don't like to get wet, though I've had them wet as well, and after a through drying, cleanup, and reprep, they keep right on working.
    Darin E. Jordan - Renton, WA
    "Self-proclaimed skill-less leader in the hobby."

  10. #10
    Join Date
    May 2007
    Location
    NY
    Posts
    1,556

    Default

    First let me say that my problem has nothing to do with failures. I have had one ESC failure since I started in FE boats 3 years ago and that was because of a dead short in my Feigao motor. EVERY boat I own has a Castle ESC in them. My problem is when I switched to the 1.4 Firmware, I noticed a huge difference in how my boat ran and the temps of everything after a run. I am not going to sit here and type it all out for the tenth time. I emailed Joe Ford and explained my problem which is the same problem others have had with the 1.4 firmware. YES i know on most of my controllers I can switch back to 1.3 and be happy BUT with the newest HV esc's that isn't a option. I Hope to GOD that this doesn't turn into a Castle bashing thread, I just want them to see that there is a bug in the 1.4 firmware and give us HV users the option to go back to 1.3 and live happily ever after.
    Team Liquid Dash

  11. #11
    Join Date
    Apr 2007
    Location
    wa
    Posts
    1,384

    Default

    I also want to state I have had none fail. I just noticed a slight speed change and drastic temp change between the two versions. I am about to buy my 4th and am loving the ease of programability and peace of mind that they are backed up by good people. Im leaving mine at older firmware and will have no trouble.

  12. #12
    Join Date
    Apr 2007
    Location
    WA
    Posts
    8,310

    Default

    Quote Originally Posted by Mich. Maniac View Post
    Im leaving mine at older firmware and will have no trouble.
    Mine are also all at the older firmware version (V1.13??)... Based on the poor reports of the later version, I won't be changing it anytime soon...
    Darin E. Jordan - Renton, WA
    "Self-proclaimed skill-less leader in the hobby."

  13. #13
    Join Date
    May 2007
    Location
    NY
    Posts
    1,556

    Default

    Just be aware when you buy a newer ESC you won't be able to go back to version 1.3......then it won't just be my problem but your's too. There is no way that upgrading the ESC firmware should slow a boat down by 5mph or more and run the motor 30 degree's hotter.
    Team Liquid Dash

  14. #14
    Join Date
    Apr 2007
    Location
    wa
    Posts
    1,384

    Default

    Quote Originally Posted by Raydee View Post
    Just be aware when you buy a newer ESC you won't be able to go back to version 1.3......then it won't just be my problem but your's too. There is no way that upgrading the ESC firmware should slow a boat down by 5mph or more and run the motor 30 degree's hotter.
    Yes yes, Then there will be problems. Not just by you but by everyone. You are very correct. Hmm. Kinda makes me second think about that 250.00 purchase. I may just wait. Good point Ray.

  15. #15
    Join Date
    Apr 2007
    Location
    Ga
    Posts
    5,161

    Default

    Quote Originally Posted by Darin Jordan View Post
    Mine are also all at the older firmware version (V1.13??)... Based on the poor reports of the later version, I won't be changing it anytime soon...
    I agree. I also recall Joe asking people on this forum who have had issues to contact him, have you done so?? Is he working on it?? My guess is that they are, and perhaps some of you are growing impatient.

    Our old 80s and 125s have been flawless since the firmware change a couple of years ago when there was a cogging issue. The Hydra 120s and 240s have also been flawless.
    I have no opinion on the HVs as we haven't used them.

    Hang tough fellas, they'll get "it" straightned out.

    Doug
    TOY BOAT RACER
    IMPBA Dist.13 Director
    IMPBA National Records Director 2009-2019
    IMPBA 19887CD
    NAMBA 1169

  16. #16
    Join Date
    Aug 2007
    Location
    CA
    Posts
    3,027

    Default

    I agree with Darin... the ESCs are solid.
    Please be patient guys, don't jump the gun and
    start assuming the ESCs are not worth using...
    If your favorite team of your favorite sport lost
    ONE game, would you go and find another team to cheer for?
    I think not, so give Castle some time to go thru the 1000's of line
    of code and find the inadequate numbers and fix it.
    :::::::::::::::. It's NEVER fast enough! .:::::::::::::::

  17. #17
    Join Date
    May 2008
    Location
    TX
    Posts
    1,744

    Default

    Does this problem apply to the 120amp HV esc? I am getting slower speeds than I expected on my new boat, but am not sure this is the problem. Has anyone done a comparison of this controller on the new firm ware to the old version?

  18. #18
    Join Date
    Dec 2007
    Location
    WA
    Posts
    102

    Default

    I may be wrong, but as I understand it the HV Hydras aren't able to revert to the older versions.

    And for the record I too have used CC exclusively since switching to brushless and have had no problems on version 1.3. I love my Hydra 240 and my Bar 125!

    I think it would be nice if someone could chart some runs w/ a data logger on the same boat using versions 1.3 and 1.4. That should give Mr. Ford a good understanding of what's going on.
    Last edited by icelert; 09-02-2008 at 08:18 PM.

  19. #19
    Join Date
    Jul 2007
    Location
    mn
    Posts
    658

    Default

    Hey guys I never meant this to be a bashing post... I am saying that I have read alotof posts recently about hydras..This that the other... Just for numbers sake 1/2 of the issues are bad set ups/programs... Another 25% for firmware issues.. Then the unknowns... My intent was for maybe some post from them that will address the firmware issue. There may be another common demoninator here also we are not seeing ,but I am sure they are..
    A statement made now just might prevent a bunch more hydras with issues...
    I own a 25 amp castle and a cc80. I have not run either as of yet. I will be hooking the cc80 up to a 10L on 12 cells in a pickle hope she holds...

    I I hope to get a 240 for my mono after this settles down. Or a 180 ?
    No bad intentions no bashing not what this post is about.
    I am a bystander here I have just seen a large increase in hydra post's
    Dave

  20. #20
    Join Date
    Apr 2007
    Location
    wa
    Posts
    1,384

    Default

    Ray, if you dont mind me asking... You once stated you found a weird throttle curv after programming. I think it was you. What did it look like? I know it should not matter but what IF you ran a wot @ 80% and up? This way once its open you KNOW its open and not a step or 2 off. Its surely not a remedy but just throwin stuff out there. I had a Heli act like this once and it was not truly obtaining enough Throttle even though curv was linear.

  21. #21
    Join Date
    Sep 2007
    Location
    NJ
    Posts
    1,253

    Default

    I recently let the genie out of two of the 120's ..... Bad product ...NO way ... just my stupidity ! My son asked me how the castle link worked so.... I showed him changed a couple of values thought I changed back to the default settings and didn't!!!!

    Should have checked twice but ---- Father knows best you know!
    We did it with a Bang!

    Cats Are Where It's At!

  22. #22
    Join Date
    May 2007
    Location
    NY
    Posts
    1,556

    Default

    Mike, the very first time I updated one of my Hydra 120 ESC's to 1.4 my boat wouldn't run at all. When I hooked the Castle link up to the controller the throttle curve was completely flat at zero. Once I returned the curve back to linear the boat ran but never like it did on 1.3. It def isn't a throttle curve problem.

    For anyone that wants to see first hand what is happening with 1.4 just take your boat that you know is running good and just update your ESC to 1.4. Don't change anything else on your setup or settings and I will guarantee you will see a performance difference and more heat than normal. I have tried it with three different controllers now and two different hulls. I swear it feels like 1.4 has a restrictor on it and it feels like the boat doesn't run full throttle even though the red LED on the controller says otherwise. Also keep in mind that the motor is what is showing all the extra heat and not the ESC so its not like the esc is getting hot from excessive part throttle running. It really almost seems like the timing may be off in version 1.4? All I know is something changes from 1.3 to 1.4 and I would just be 100% happy to be able to switch ALL my Castle ESC's back to 1.3. I am hoping Joe and the Castle guys will give me a way to do this on my HV 180 since I already am able to do it on my other CC controllers and not on the HV controller.
    Team Liquid Dash

  23. #23
    Join Date
    Dec 2007
    Location
    WA
    Posts
    102

    Default

    "For anyone that wants to see first hand what is happening with 1.4 just take your boat that you know is running good and just update your ESC to 1.4. Don't change anything else on your setup or settings and I will guarantee you will see a performance difference and more heat than normal"

    Not to fan the flames here Ray but did you re-bind the rx to the tx after changing the firmware?
    I remember Joe saying that re-binding was a must do.

    Like I mentioned I love Castle's products. In the engineering world there is a thing called a safety factor. It is designed into products for obvious reasons. Castle is one of a very few that are built with such safety factors. Problem is that too many abuse that or don't understand it enough to prevent the magic smoke from escaping. I say that not because of what we are discussing, but because of what Castle must have to deal with. Many of the lesser priced ESC's out on the market can't survive under their own ratings, but people are willing to take a chance because the investment is less and/or they are using safety factors of their own.

    As many of you know running a fast electric boat requires knowledge that there always is going to be a weak leak in the system. Understanding what that weak link is and acquiring the means to monitor and control it is the key to success and longevity.

    This is a wonderful discussion, and I hope Castle will come forth with some info soon to help us better understand the reasons behind the firmware revisions and what maybe happening to improve the performance on revision 1.4.

    bryan

  24. #24
    Join Date
    Aug 2007
    Location
    CA
    Posts
    3,027

    Default

    Ray did and I did rebind Rx/Tx... there is def something going on...

    I am leaving the pros to deal with it... Joe as always helped the boaters out... let's give the guy a chance to fix things, he may be in the middle of nowhere but I think they do have holidays there as well
    :::::::::::::::. It's NEVER fast enough! .:::::::::::::::

  25. #25
    Join Date
    May 2008
    Location
    TX
    Posts
    1,744

    Default

    Isn't there a way to test the esc to ensure that it is really at full throttle? I seem to remember you unplug the motor and pull the trigger and look for a solid red light that tells you you are at full throttle on the esc. Is this correct?

  26. #26
    Join Date
    Aug 2007
    Location
    CA
    Posts
    3,027

    Default

    that would work based on the fact that the software is giving the LED the signal to turn on at the right time... what if the software is only outputting 80% of the power and tells the LED that it is full throttle?
    If there is something that does not seem right, chances are there is a hiccup somewhere, whether is user error or hardware.
    Last edited by Ub Hauled; 09-03-2008 at 03:29 PM.
    :::::::::::::::. It's NEVER fast enough! .:::::::::::::::

  27. #27
    Join Date
    Apr 2007
    Location
    Ga
    Posts
    5,161

    Default

    CASTLE CREATIONS 913-390-6939

    Call them and put this to bed.
    Last edited by Doug Smock; 09-03-2008 at 02:05 PM.
    TOY BOAT RACER
    IMPBA Dist.13 Director
    IMPBA National Records Director 2009-2019
    IMPBA 19887CD
    NAMBA 1169

  28. #28
    Join Date
    Jun 2007
    Location
    BC
    Posts
    5,190

    Default

    Ah, Doug my mentor and mate. There have been problems with V1.4 and as of this date Joe has not addressed the problem.

    Douggie

  29. #29
    Join Date
    Apr 2007
    Location
    Ga
    Posts
    5,161

    Smile

    Quote Originally Posted by Flying Scotsman View Post
    Ah, Doug my mentor and mate. There have been problems with V1.4 and as of this date Joe has not addressed the problem.

    Douggie
    Hi Douggie,
    I just figured if Joe wasn't here, maybe some GOOD information may come from contacting them. I'd be calling twice a week until I had an answer.

    Your mentor? Man when I grow up, I want to be just like you!!

    Doug
    TOY BOAT RACER
    IMPBA Dist.13 Director
    IMPBA National Records Director 2009-2019
    IMPBA 19887CD
    NAMBA 1169

  30. #30
    Join Date
    Jun 2007
    Location
    BC
    Posts
    5,190

    Default

    Quote Originally Posted by D.Smock View Post
    Hi Douggie,
    I just figured if Joe wasn't here, maybe some GOOD information may come from contacting them. I'd be calling twice a week until I had an answer.

    Your mentor? Man when I grow up, I want to be just like you!!

    Doug
    Oh my God, two assholes in heaven. The Jihad had better watch out, as I think the virgins will be taken

    Douggie

Page 1 of 2 12 LastLast

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •