Results 1 to 4 of 4

Thread: GP-1 ESC issues

  1. #1
    Join Date
    Feb 2009
    Location
    IN
    Posts
    39

    Default GP-1 ESC issues

    Hey Everybody,

    Having major issues with the esc in my GP-1. Original was DOA from the beginning, then the replacement tried to burn my boat down after 2 minutes run time. Second one also tried to fry the motor. Is anyone else having problems with the factory 30A AQ ESC or are mine isolated incidents?

  2. #2
    Join Date
    Sep 2013
    Location
    IN
    Posts
    849

    Default

    Any kind of wetness on them and its nothing but bad news, its bone dry or they break. I'd seal them before even hitting the water, there are a ton of methods to do this, I'm not going to get into which is the best method......

  3. #3
    Join Date
    Feb 2009
    Location
    IN
    Posts
    39

    Default

    Turns out it wasn't an ESC fault. I discovered one of the internal motor leads broke and was shorted to the motor case. As we all know, QC on these Chinese RTRs is suspect at times, but Tower warrantied the motor, no questions asked. I have to say, I've always been impressed with their customer service and they really stand behind their products. Couldn't have asked for a better outcome.

    Thanks trigger, just an fyi the ESC comes factory sealed in rtv wrapped in shrink material.

  4. #4
    Join Date
    Sep 2013
    Location
    IN
    Posts
    849

    Default

    Mine was not sealed other than the shrink that has two wide open ends, my mini mono was the same. Up to you but I'd double check it.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •