Results 1 to 8 of 8

Thread: Mini Rio Newbie Qns

  1. #1
    Join Date
    May 2011
    Location
    sg
    Posts
    4

    Default Mini Rio Newbie Qns

    Just got my hands on my mini Rio yest. Upgraded to brusless with this set up:

    Hobbywing Seaking 35A
    Align 400 size 2700kv b/l
    stock prop
    3s 1300mah Lipo with deans

    Boat still had the issue of getting on plane .. moreover it kept self turning to one side irregardless of trim . kept havin to counter steer to keep straight , is it coz of the batts n weight balance of the boat? ... it's only after a few correct turns or keeping it straight for abit than it boat catches on plane an starts zooming away at an amazing speed .. is this normal for boats ?

    sorry guys it's my 1st foray into RC boats .. soo I'm just v v lost .. feels my boat is too heavy at the back . mounted the RX there ... esc weight is rear bias too .. should I move it more to the front hatch?

    Any advice on changing the props soo that it's easier to get on plane immediately ?


    regards and thanks guys
    Last edited by doggie; 05-28-2011 at 02:00 AM. Reason: typo

  2. #2
    Join Date
    Jun 2010
    Location
    Mi
    Posts
    635

    Default

    The mini Rio likes front balance balance, around the center of the front access hole.

    Might also be the prop. Im not sure what the stock setup was, but broke mine.
    I ended up gutting the hull, installing a new drive setup and hadrware. I use a plastic y531 prop.

    https://forums.offshoreelectrics.com/...hp?albumid=403

    I ended up dticing the spacer on the strut. It was porposing.
    Cheetah, Super Rio, (Mod) Starship (Mod and sold),

  3. #3
    Join Date
    Jul 2009
    Location
    FL
    Posts
    5,669

    Default

    When I had mine bfore the abyss took it, I mounted my motor just about where the original was, battery was under the part of the deck between the two access holes, a little more towards the rear, esc was mounted on the foam in the bow. RX was to the starbord side of the motor mount... I think. It took off very well and was crazy to run.

    I also ran the strut Larry showed and the mini rudder as well.

    Biggest thing I can say is add flotation. It will sink if you blow a hatch seal which is what I did. 6 feet of water and its been down since April of '10. I gave up looking for it as I think the lockness ate it.

  4. #4
    Join Date
    May 2011
    Location
    sg
    Posts
    4

    Default

    Quote Originally Posted by larryrose11 View Post
    The mini Rio likes front balance balance, around the center of the front access hole.

    Might also be the prop. Im not sure what the stock setup was, but broke mine.
    I ended up gutting the hull, installing a new drive setup and hadrware. I use a plastic y531 prop.

    https://forums.offshoreelectrics.com/...hp?albumid=403

    I ended up dticing the spacer on the strut. It was porposing.
    hey thanks !! I now mount my eSc the same way u did ... getting more weight to the front ... it now gets on plane almost immed.. it's still steering towards left thou . I'm trying to compensate using my controller settings thou . speeds great .. but I flipped ovr twice tonite ..(now i lower my EPA and EXp) had to dive into my pool to retrieve it.. can't wait to test some ore b4 bringing it to the pond ...

  5. #5
    Join Date
    May 2011
    Location
    sg
    Posts
    4

    Default

    Quote Originally Posted by tiqueman View Post
    When I had mine bfore the abyss took it, I mounted my motor just about where the original was, battery was under the part of the deck between the two access holes, a little more towards the rear, esc was mounted on the foam in the bow. RX was to the starbord side of the motor mount... I think. It took off very well and was crazy to run.

    I also ran the strut Larry showed and the mini rudder as well.

    Biggest thing I can say is add flotation. It will sink if you blow a hatch seal which is what I did. 6 feet of water and its been down since April of '10. I gave up looking for it as I think the lockness ate it.
    Oh my sorry to head abt yr lost ... I'm still running my in my pool thou at abt 70% settings ... stock prop... how do u add flotation? add more foam into the boat ?

  6. #6
    Join Date
    Jul 2009
    Location
    FL
    Posts
    5,669

    Default

    Quote Originally Posted by doggie View Post
    Oh my sorry to head abt yr lost ... I'm still running my in my pool thou at abt 70% settings ... stock prop... how do u add flotation? add more foam into the boat ?
    Yeah just add some cut up pool noodles or something.

    I used to have this as my signature...

    Final moments of the Brushless mini rio in emoticons.

  7. #7
    Join Date
    May 2011
    Location
    sg
    Posts
    4

    Default

    boats been running great .. snapped my stock drive cable on my 4th run... *went swimming yet again*

  8. #8
    Join Date
    Jun 2010
    Location
    Mi
    Posts
    635

    Default

    Doggie,
    That happened to me. I took out the stock stuffing tube, and upgraded to the 0.98 flex. Didn't happen any more.
    I smashed it bad last season, SO, Im gutting the Mini Rio right now for am major overhaul. Lots of new fibrerglass. Re-doing the top deck and hatch to I can tape it well. New layout with a ADS400XL motor near the back, bigger batteries at the front, since they are the heaviest part. Pics to come.
    Cheetah, Super Rio, (Mod) Starship (Mod and sold),

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •