PDA

View Full Version : hello all. my new blackjack 29 not working.



marm1
11-10-2014, 05:13 AM
Hello to all fellow boaters. I just got my first fast Electric its a Black Jack 29. With a leopard 2100 kv. And a 120 esc. On its first run yesterday went ok for first 2 mins then motor started juddering . And now all it is doing is beeping constantly. Reciver is good.. batterys all charged. Can anyone help as im not sure what else to check. I have tried to rebind it . But still the same. Steering servo not working. Thanks for any replys ..

tlandauer
11-10-2014, 11:28 PM
Did water get into the hull during your previous run? What radio system? ( I ask if you use Spektrum MR3000, then water should not be an issue).
Moisture in the receiver will give you lots of trouble.
Use a separate receiver pack and hook it to your receiver and plug in your servo ( assuming that you are 100% sure that the servo works), if the servo doesn't respond, chances are that the Rx is not working.
if , on the other hand, the servo is responding, then you need to look into your ESC, because the BEC on the ESC should provide needed electricity to the Rx's 1st channel for the servo to respond. Regardless if the ESC has been programmed/calibrated or not.
Note that normally the constant beeping is indicative of a non-proper programing and/or throttle trim adjustment, on Futaba and /or Futaba based systems (Tactic and FlySky) you need to set the throttle channel to reverse. But all this should not prevent the servo from responding, therefore, it is possible that your ESC has some kind of malfunction.
In any case, this is how I will go about eliminating the usual suspects.

P.S.
While we are assigning the blame on your receiver, let's not forget that your Tx could be the culprit, have you used fresh batteries or made sure your rechargeable Tx battery is in good order? And,for that matter, your Tx is working?